Mac

CVE-2020-5260 – macOSのgitをアップデート

gitに脆弱性が見つかったというニュースがあります。
[Announce] Git v2.26.1 and others – Junio C Hamano
Gitに認証データ窃取の脆弱性、アップデートを
CVE – CVE-2020-5260
「Git」に複数の脆弱性、Windowsユーザーはとくに注意
手元のgitのバージョンを調べると2.24.1。

$ git --version
git version 2.24.1 (Apple Git-126)
$

「git 2.24.1およびこれよりも前のバージョン」に該当しました。

Apple GitはXcodeからインストールされているgitなので、リリースされているアップデートを適用すればok。(8.1GBあるので通信環境によっては要注意)

macOSがこの脆弱性の影響を受ける条件は限られているようですが、もちろん最新版にしておかない理由はありません。

アップデートをインストールしたら、Xcodeを起動しなくてもgitは新しいものになっていました。

$ git --version
git version 2.24.1 (Apple Git-126)
$ git --version
git version 2.24.2 (Apple Git-127)
$ $

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です